Yosemite - gammal SSL/TLS?

Tråden skapades och har fått 9 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Karlskoga
  • 2021-10-09 12:03

En gammal iMac early 2009 med Yosemite kan inte köra https längre, rotcertifikatet har fel datum (trots att det står till nov 2021).
Jag ska installera ElCapitan som ska vara det senaste datorn klarar. Men varför dök detta fel upp helt plötsligt? Kan man ladda ner ett nytt rotcertifikat? Elak programvara (Malwarebytes hittade inget)?

  • Medlem
  • Göteborg
  • 2021-10-09 12:51

Vilken webläsare/version? Vilken webtjänst?

Minns inga detaljer på rak arm, men en något äldre imac kunde använda t.ex banktjänster via Chrome istället för Safari tills det också la av och den pensionerades.

  • Medlem
  • Strängnäs
  • 2021-10-09 23:06

Det är ganska mycket med SSL/TLS som gått sönder denna sommar för OSX 10.11 då de flesta servercert slutat stödja de algoritmer som är max för 10.11.

Min mamma kan t ex inte längre köra krypterad uppkoppling till mailservern.

Synd att behöva slänga den men jag får väl uppdatera maskinparken hemma och skifta ut min 2017 imac till henne.

  • Medlem
  • 2021-10-10 00:49

Det är rotcertifikaten som har gått ur tiden.
Nikka tar upp problemet i senaste avsnittet av Bli säker-podden. Börja lyssna vid 12:50.

https://nikkasystems.com/2021/10/08/podd-137-...

Det korta svaret är att man måste uppdatera operativsystemet, MacOS Sierra är minimikravet för att detta ska fungera. Tyvärr ser det ut som att El Capitan är den sista supportade versionen för denna dator?

Att slänga in Windows kan kanske vara ett sätt att kunna hålla maskinen vid liv ett par år till?

Senast redigerat 2021-10-10 01:16
  • Medlem
  • 2021-10-10 02:35

Jag har en Imac Early 2008 som jag kör High Sierra på utan problem, med hjälp av High Sierra Patcher. Annars finns det systemcertifikat för Sierra 10.12 att installera via den här bundlen (direktnedladdning). Jag lämnar inga garantier för moddande av datorn, det gör man på egen risk.

  • Medlem
  • Karlskoga
  • 2021-10-11 14:15

Bundle i föregående inlägg visar Leopard webkit för PPC, är det rätt?

  • Medlem
  • 2021-10-11 19:29
Ursprungligen av kenjon:

Bundle i föregående inlägg visar Leopard webkit för PPC, är det rätt?

Ja, det är rätt, så till vida att det är samma problem, så att säga: Safari i Leopard för PPC går heller inte att surfa med, delvis beroende på för gamla systemcertifikat. Däremot är skriptet förstås tänkt för just Leopard 10.5.8. Men innehållet är hämtat från Sierra 10.12. Är det då garanterat så att det funkar i El Capitan 10.11? Nej, inte alls, så jag råder dig att testa på en klonad backup om du är orolig för att något havererar. Men det är en möjlig lösning.

Har samma problem. Kommit runt det delvis genom att kryssa i rutan "Inget skydd" under säkerhetsinställningar i Chrome.
Vissa sidor fungerar ändå inte men de flesta går att se om man kryssar sig förbi varningen.
Har program installerade på min MacBook Pro som inte fungerar på senare versioner av OS.

  • Medlem
  • 2021-10-14 12:12
Ursprungligen av Claes Löfgren:

Har samma problem. Kommit runt det delvis genom att kryssa i rutan "Inget skydd" under säkerhetsinställningar i Chrome.
Vissa sidor fungerar ändå inte men de flesta går att se om man kryssar sig förbi varningen.
Har program installerade på min MacBook Pro som inte fungerar på senare versioner av OS.

Intressant. Var hittar man den inställningen? Chrome:flags?

Ursprungligen av Alix:

Intressant. Var hittar man den inställningen? Chrome:flags?

Chrome:Inställningar: Sekretess och Säkerhet: Säker webbsökning

1
Bevaka tråden